Dreamweaver CS6 Basics
Learn the basics of Adobe Dreamweaver by creating a new page and inserting common HTML
elements such as links, images and lists using the WYSIWYG interface.

Objectives
o
o
o
o
o
o
o

Create a Site Definition
Understand the Adobe Dreamweaver CS5 Interface
Add Basic Text Formatting (bold, italic, headings)
Create Lists
Insert Images
Insert Links
Validate the HTML pages

What is Adobe Dreamweaver?

Adobe Dreamweaver is a professional web editing application for building and managing
websites and native mobile apps. Dreamweaver is one example of a What You See Is What You
Get (WYSIWYG) software application. This is a term used to describe web-developing software
that writes HyperText Mark-Up Language (HTML) code based on the text, images and layout
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Setting Up A Site in Dreamweaver with an FTP Connection

Setting up a site in Dreamweaver is the first thing that should be done when working on a new
website. While this setup process isn't required to begin working, site definition is highly
recommended to avoid issues involving link updating and file management.
On the Welcome Screen, click on the Dreamweaver Site icon under the "Create New" heading.
Alternately, go to the Site menu and choose "New Site".
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Site Definition

1. In the Site Name field, give your site a descriptive name.
2. Next to the Local Site Folder field, click on the folder icon to navigate either to your public_html
folder (or a folder saved on your computer where your site files will be stored).
3. If you are navigating to your public_html folder on campus, click Save. You will now see a
cache of your folder's contents in the Files Panel. If you are using another hosting provider,
click on the Servers button.
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4. Enter the information above for your hosting provider account.
5. Click the Save button at the bottom of the dialog box.
6. Click Save again at the bottom of the Site Setup dialog box. For information about uploading
your site files to this remote server, read the section "Uploading your Site to a Remote Server" at
the end of this document.

Creating and Saving a New File

Creating new documents is simple in Dreamweaver, and there are many ways to quickly create a
new page:
•
From the Welcome Screen, click HTML from under the "Create New" heading. This will create
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•
•

a blank HTML document.
Select File > New. This will open the New Document dialog box, which lets you choose from
more options.
Right-click on the folder icon in the Files panel next to the name of your site and choose "New
file". This will not open the document, but will instead add the document into your Files panel
list and allow you to rename the document. This is convenient for creating future pages you
would like to have but aren't ready to work on yet.

Note: Before you continue, it is very important that you save your file first! You don't want to
unexpectedly lose your work. In this lesson save the file as services.html
Naming Conventions
(adpated from http://caheinfo.wsu.edu/webtips/names.html)
Here are some things to avoid when naming files or folders for Web use:
•
spaces (For example, my file.html is an invalid filename.) Do you ever notice the characters
%20 in a URL? This results when the browser or server converts a space in a URL into a code
that is more universally understood by computers.
•
periods that do not immediately precede a file extension (myfile.html is correct; my.file.html is
not)
•
any character that is not a letter, number, dash, or an underscore (while underscores are
legal, they are often unnecessary, creating barriers in linking and typing the URL)
•
capitalization (Technically, capitalization is legal, but like underscores, capital letters may not
be recognized properly and create unnecessary barriers in linking and typing the URL.)

Changing Views in the Document Window

•
•

•

Code View - This option allows you to view your web page's entire HTML coding as it is
generated by Dreamweaver.
Split View - This viewing option divides both the Design and Code view to allow you to see
the HTML coding as you lay out your website. One pane displays your HTML code while the
other pane shows you the page as it may appear in the web browser. This view allows a
designer excellent mobility between the coding and the layout. It is also best used when you
want to debug or troubleshoot a web page.
Design View - This option is the primary view that allows you to edit your web page the way it
may appear in your web browser without needing to manually enter code.
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Document Toolbar

The rest of the Document Toolbar includes many other important features:
1. Live - Preview what your page will look like live on the Web without leaving Dreamweaver.
Click the Live View button to toggle these views. You cannot edit your page in Design view
while Live is active; you must click the button again to leave Live view.
2. Multiscreen Preview - Test what your page will look like at different breakpoints.
3. Preview/Debug in Browser - See your page on any browser you have installed on your
computer. Always test your webpages in multiple browsers as there are many
differences on how each browser might interpret the HTML code.
4. Validate Current Document (W3C) - Test for validation within Dreamweaver.
5. Visual Aids - Display or hide element borders in Design view.
6. Title Field - Enter a title for your page, no longer than 65 characters. This text is visible to
visitors in the browser and in search engine results.

Workspace Layouts

Dreamweaver provides preset workspace layouts designed to suit different types of developers or
projects. To switch workspace layouts, select a layout from the workspace switcher, in the top-right
corner of the application window, as shown in the screenshot. For this tutorial, leave Dreamweaver
in the default "Designer" workspace.
Creating a Custom Workspace Layout:
In addition to using the default workspace layouts, you can also arrange the workspace to your
specific needs and save that layout for later use.
1. Arrange the panels and toolbars in the workspace as desired.
2. From the workspace switcher menu, choose "New Workspace". The "New Workspace" dialog
box opens.
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3. Enter a descriptive name for the workspace and click OK. The new workspace name appears at
the top of the application window. You can rename or delete custom workspaces by choosing
"Manage Workspaces" from the workspace switcher menu.

Exploring Dreamweaver

Dreamweaver's workspace consists of the Document Window and a collection of panels, each
containing a series of options for formatting, managing and inserting content.
Document Window: the browser-approximate main workspace where web pages are created and
edited using the panels and toolbars.
Files Panel: view and manage the files in your Dreamweaver site.
Insert Panel: create and insert new elements (anything that is manually inserted onto your
Document Window). The buttons found in this toolbar are organized into categories. Select
catagories using the dropdown menu above the icons.
Properties Panel: edit the attributes and formatting of any page element that is currently selected
on your web page. Take note that your Properties Panel buttons and options may change to reflect
any attributes of any selected element, such as when an image is selected.
Quick Tag Editor: Displays how a selected element is nested and lets you change code while still
in Design view.
Multiscreen Preview: Test your page to see how it will render at three common device
breakpoints.
Embedded within is the document toolbar that includes three main viewing options: Code, Split,
and Design. These three viewing options help you view and manipulate your web pages.
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The Title Element

In the Document toolbar's Title text field, type in the title. Press Enter (Windows) or Return (Mac).
This will define the page title for this page.
The page title appears at the top of the browser when the page is being viewed, in search engines
when your site is listed among search results, and is the name used by browsers when the page is
bookmarked. Titles should be less than 65 characters (including spaces) to prevent getting cut off
when listed in search engine results. The most important/unique part of the title should come first.

Adding and Formatting Text
Formatting text in Dreamweaver is the same as using a standard word processor, such as
Microsoft Word. You can set formatting styles (such as Paragraphs, Heading 1, Heading 2,
Heading 3) for a block of text, and apply text styles such as bold, and italic. Other formatting
options such as changing the font, size, color, and alignment of a selected text should be done in
CSS, not in HTML.
Text is entered into Dreamweaver by either typing directly onto the Document Window or inserting
the text directly into the code using the Code view. Once this text is in the Document Window you
can format it very similar to most word processors. Pressing Enter (Windows) or Return
(Macintosh) create a new paragraph.

Adding a Heading with the Property Inspector

1. Place your cursor in the Document Window in the desired location.
2. Select from the Property Inspector under Format, Heading 1
3. Type the desired text for your Heading 1.
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Text Format in the Property Inspector

Dreamweaver contains three basic paragraph styles: paragraph, heading, and preformatting.
They are applied using the Format drop-down list in the Property Inspector panel.
•

•

•

Paragraph - This format ignores white space, so extra spaces within the paragraph appear as
only one space when viewed in a browser. Paragraph format uses the HTML code <p>…</p>,
which indicates the text will automatically wrap.
Heading - Headings are used to identify different sections of content on a page. They range
from largest and boldest <h1> to smallest <h6>. Headings are applied to the entire paragraph,
so you can't mix heading styles within the same line of text.
Preformatted - The preformatted format enables you to space text exactly as you want,
including using white space and line breaks. Text doesn't automatically word wrap, so you
must press Enter to end a line.

Adding Paragraphs

1. Press Enter (Windows) or Return (Macintosh) after the Heading 1 or previous text. Pressing
enter designates any following text as a plain paragraph until formatted differently.
2. Type in your paragraph text. Hit Enter/Return to start a new paragraph.

Adding Line Breaks
The <br /> tag is a forced line break within a block element. In the Code view, the previous
screenshot is what the line break will look like.
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Follow any of these simple steps in order to insert a line break:
o Press Shift + Enter (Windows) or Shift + Return (Macintosh).
o In the Text category of the Insert bar, select Character and click the Line Break icon.
o Select Insert > HTML > Special Characters > Line Break.

Spell Check
Use the Check Spelling command to check the spelling in the current document. The Check
Spelling command ignores HTML tags and attribute values.
By default, the spelling checker uses the U.S. English spelling dictionary. To change the dictionary,
select Edit > Preferences > General (Windows) or Dreamweaver > Preferences > General
(Macintosh), then in the Spelling Dictionary pop‑up menu select the dictionary you want to use.
Dictionaries for additional languages can be downloaded from the Dreamweaver Support Center
at www.adobe.com/go/dreamweaver_support.
1. Select Commands > Check Spelling or press Shift+F7. When Dreamweaver encounters an
unrecognized word, the Check Spelling dialog box appears.
2. Select the appropriate option based on how you want the discrepancy handled.

Bolding Text with "Strong" Tag

1. In the Document Window select the text that you would like to bold.
2. In the Property toolbar, click on the bold icon, or use the keyboard shortcut Ctrl/Cmd + B.
Inside the Document Window in Design View, you will notice that the highlighted text is now bold.

Italics with the "Emphasis" Tag

Similar to bolding text, it's simple to format text as italics:
1. Select the text that you would like to italicize.
2. In the Property toolbar, click on the Italics icon, or use the keyboard shortcut Ctrl/Cmd + I.
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Inside the Document Window in Design View, you will notice that the highlighted text is now
italicized.

Adding a Second Heading and an Unordered List

Before writing a list, we are going to add a title, something to describe your list. Type the title for
your list and highlight the text, and select Heading 2 from the Properties Panel.
Click on the unordered list icon (the bulleted list icon) in the Properties Panel.
1. Type in the first item in your list. After doing so, click enter, and there is a second bullet created
below the first.
2. Finish the list with as many items as you like. To change from a list to a plain paragraph press
Enter/Return twice.

Adding a Third Heading

Before our next step where you'll add an image, you might want to add a title for this next section of
our page.
Type the title for your text, select the text and, select Heading 3 or an appropriate heading level
from the Properties Panel.
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Adding an Image

1. In the Insert Panel, choose Common from the drop-down menu (if not already open).
2. Under the Common menu, choose the icon with a little tree - it should say Images next to it. After
clicking on the icon, select Image to bring up the dialog box.
3. Navigate to where the image is located.
If the picture is located on your hard drive but not in the public_html/site folder, then a pop-up dialog
box will appear. If you are prompted with this box, you will want to click on yes. After doing so,
Dreamweaver will create a copy of the file, and place it into your root directory (the place where
your images will be saved).

Alternate ("Alt") Text

After clicking on "yes" to the "files outside of the root folder" (if you happen to get this screen) or
after hitting OK, you will be brought to the second dialog box.
Alternate text provides a text equivilent for elements like images. Alternate text is helpful for those
using assistive technologies such as a screen reader (in which case the alternate text will be read
aloud), or those who cannot load images (the alternate text will be displayed instead of an image).
To change your alternate text, you can easily correct it by clicking on the image and using the
Property Toolbar. You can change the alternative text in the alt field of the toolbar.
From the W3C: http://www.w3.org/QA/Tips/altAttribute
The generic rule for the content of the alt attribute is: use text that fulfills the same function
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as the image.
Some more specific rules:
•
if the image is simply decorated text, put the text in the alt attribute
•
if the image is used to create bullets in a list, a horizontal line, or other similar
decoration, it is fine to have an empty alt attribute (e.g., alt=""), but it is better to use
things like list-style-image in CSS
•
if the image presents a lot of important information, try to summarize it in a short line
for the alt attribute and add a longdesc link to a more detailed description

Image File Formats

Creating an E-mail Link

When users click on an email link, the user's default email application (Outlook, etc) will
automatically launch a new email message with the linked email address already entered in the
To: field.
The following steps are ways to create an email link:
1. Drag-select the text to be hyperlinked. This will highlight the text. Make sure the text describes
who the email is going to.
2. In the Properties Panel, type in the command "mailto:" then an email address, all as one word
with no spaces. Watch your spelling!
3. Hit the Enter/Return key to create the link.
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Creating a Relative (Internal) Link using Text

Create text or image hyperlinks to a specific file/webpage using the Properties Panel.
1. Type the text you would like to hyperlink and drag-select it.
3. Click the Browse for File icon, next to the Link option, in the Properties Panel. Select an HTML
page from your web site, for example your index or home page. Click OK. This text is now linked to
an HTML page within your website.
4. Hit Enter/Return to make the selected text a link. This link is called a Relative Link. It is relative
because it is linked to a document within this site, not to an external webpage on another domain.

Creating an Absolute (External) Link

An absolute link begins with an "http://" header and includes a full address to a webpage/file.
The process is almost identical to creating a relative link:
1. Select the text that you want to hyperlink.
2. Type the entire the URL into the Link option in the Properties Panel and press Enter/Return.
3. Click OK.

Creating an Image Link

1. Select an image that you want to become a hyperlink.
2. Enter the filepath/URL for the file/webpage into the Link field in the Properties toolbar and
press Enter/Return.
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TIP: If your URL is long and complicated, it's best to go to that page in a browser and copy and
paste the URL from the browser into Dreamweaver. This will ensure no typos are made.

Adding Special Characters

There are times when your text may contain special characters and diacritical marks.
Dreamweaver provides most of these special characters such as the copyright symbol(©),
trademark(™), registered(®), or an em dash(-).
To add special characters to your text:
1. Position your cursor where you want these special characters in your Document Window.
2. From the Insert Panel, choose Text from the drop-down menu and click on the Characters
icon.
3. Click on the desired symbol to insert it into your page.

Inserting Date & Time Stamps

You may want to include a date/time stamp to specify when a piece of content or a page was last
updated.
1. Place your cursor into the area where you would like to have your date stamp shown. This is
often located at the bottom of a webpage.
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2. Type “Updated on:” or “Created on:” or other text to describe the relevance of the date stamp.
3. In the Common tab of the Insert Panel, click the Date button.
4. An Insert Date dialog box will appear. Choose the format Dreamweaver will use to display the
date and time. Check the option for "Update automatically on save". This means that each time
you edit this file and save, Dreamweaver will automatically update this date and time.
5. Click OK.

Dreamweaver Resources
Dreamweaver product page: http://www.adobe.com/products/dreamweaver
Official Video Tutorials: http://tv.adobe.com
Dreamweaver Development Center: http://www.adobe.com/devnet/dreamweaver.html
For more web design resources, visit: http://www.diigo.com/list/meganura/web-essentials
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