
Tutorial: Dreamweaver
File Management & Web Design

Objective
By creating a simple portfolio Web site using Dreamweaver, students will become familiar with 
Web design basics and the importance of saving files to specific locations in a well structured 
directory.

Tools and techniques covered in this tutorial:

Organizing Web Pages and Sites

Formatting Web Pages
• HTML styles, CSS styles. Embedded objects, Links, Page properties and Head elements

Page Layout
• Div tags

Dynamic HTML
• Rollovers
Sites

• Site window, link checking

Optimizing graphics
Using Photoshop "Save for Web" to create optimized .jpg, .gif, or .png files for the Web

Grading

Considered will be:

• the proper function of all links and display of images
• clean, organized, and consistent layout
• technical execution, including proper file organization within the site, intuitive navigation from the 
home page—to each project page—and back to the home page.



Step-by-step

1. Create a basic folder hierarchy for your local site documents

In this step you will:
• Use Finder to create and name new folders for a site hierarchy.

2. Define your Dreamweaver site

In this step you will:
• Setup your site in Dreamweaver to help you create and maintain both local and remote site files 
and links.

Background info: Whenever you sit down to use Dreamweaver, you must first define the 
location of your site. By telling Dreamweaver where your local site folder resides on your 
computer, and where the remote site folder is on the Web server, Dreamweaver can help organize 
files, prevent broken links, and easily update your "live" remote site after changes are made. The 
Site window behaves much like Finder. At this point you should avoid opening and moving site 
files from within Finder in order to prevent broken links .

Do this: Launch Dreamweaver and choose Site>Manage Sites…>New>Site. You will enter your 
site configuration information in the Basic tab.

• Type in a site Name like "DMS 537 Portfolio Site". This will help you to identify it among 
others that you may develop later. Click Next.

• Leave the No button checked. You will not be using special server technology. Click Next.

• Leave the Edit local copies button checked, then click on the small folder icon to tell 
Dreamweaver where your local site folder resides. (Be extremely careful that you choose the site 
folder itself and not the images folder within it, nor its parent "Web Portfolio" folder.) Click Next.



Click Next, Next then Done. In the Files window you will see your Local site files. If you click on 
the Expand/Collapse button, you will see your Local site on the right, and your Remote site on the 
left. (The remote site will be empty until you synchronize, later.)

3. Create a new html document

In this step you will:
• Create a new HTML file and open it from the Files window.

Background Info: Any file that is part of a Web site must adhere to strict naming rules:

• Do not use spaces, special characters or punctuation other than a period "." underscore "_" or 
hyphen "-".

• Use only lowercase letters (if you do use upper case, use them consistently throughout the site, 
e.g. for the first character in every file name)

• All files must have the appropriate extension, such as .html, .jpg, .gif, .swf…

• The home page in every site must be named "index.html".

Control-click in the on the site folder in the Files window and choose New File.

Change the name of the new untitled document to "index.html".

Double-click on the index.html page icon to open the page in Dreamweaver.

Title your page by typing it into the Title field at the top of the document window. Name it 
something like "DMS 537 Portfolio".

The page title appears in the browser window's title bar and is used when visitors bookmark your 
site. This is not to be confused with the page's file name - HTML file naming rules do not apply.

4. Layout a basic grid for your page design

In this step you will:
• Set your document window size
• Draw apDiv boxes in Layout View to graphically containers for text and graphics

Do this: From the menus, select View>Grid>Show Grid. Click the Layout tab on the Insert 
bar. Select the Draw AP Div tool and draw a container starting in the upper left, dragging to the 
right and down.



The width of the will be displayed along its bottom, and also in the Property Inspector. Make your 
Div about 800 pixels wide, either by adjusting the side handles or by typing 600 into the "W" field 
of the Properties panel.

Again using the Draw AP Div tool, drag out a div near the bottom aligned with the top cell. The 
resulting cell, which will contain our site navigation links, should have a T value (distance in pixels 
from the top of the page) of 550.

Draw 3 divs along the left margin to contain thumbnail images and descriptive text. Each div 
should be 225px x 100px.

Draw a div to contain bio text, approximately 320xpx x 400px, lined up with the top thumbnail div 
and aligned along the right edge of the top and bottom elements.

5. Enter text into the divs and apply CSS formatting

In this step you will:
• Enter text into divs
• Use Cascading Style Sheets (CSS) to format text elements
• Optionally modify the CSS document to further customize your pages

Background Info: HTML provides for several simple text formats: Heading 1 <h1> through 
Heading 6 <h6> denote headline hierarchies from largest (most important head) to smallest (least 
important head). Paragraph format <p> is used for most body copy. You can specify preferred sets 
of type faces, relative sizes, color and bold/italic for any text element. In this step, we will use CSS 
to globally set type styles for specific elements anywhere they occur within our site.

CSS can also be used to control the position of DIV elements and dynamically change page layout 
for different purposes. See http://www.csszengarden.com/

Enter the following type into your index.html page:

• In the top header cell, type: 
"[Your name]" then assign heading 1 format in the Properties panel, then hit Return
"DMS 537 Portfolio", assign heading 2.

http://www.csszengarden.com/


Create CSS page:

• Show Window>CSS Styles. Click the Attach Style Sheet button at the bottom of the CSS 
Styles panel.

In the File/URL field, type in "portfolio.css".

Click Add as Link to make it available to all pages in the site. (Import would write the style sheet 
into that one document only.)

You will be prompted that such a file does not exist. Click Yes to create it.

Define new CSS Rules:

Select portfolio.css in the CSS Styles panel. Click the New CSS Rule button.

• Select the Tag button, then choose <body> from the drop down menu. This tag controls basic 
text formatting and other page properties such as background color.

In the Type category, choose a type family (such as Verdana, Arial, Helvetica, sans-serif.) Set the 
size to 11 pixels and the line height to 130%. Note the proper units: pixels for size, % for line 
height.

In the Background category, choose a pale color. (You can choose a dark color, but then your text 
should be changed to a light color.) Click OK.



• Select the Tag button, then choose <h1> (size of 24 pixels)

• Select the Tag button, then choose <h2> (size of 20 pixels).

You may modify or add other styles to the CSS page:

• Click the Tag selector to change the look of a standard HTML tag.
• Click the Class selector to change the look of any text or other HTML element.
• Click the Advanced selector to change the look of hyperlinks.
•

6. Prepare thumbnail images for rollovers in Photoshop

• Use the Crop tool, set options to 100 px x 100 px, 72 ppi. Select an area to represent the image 
as a thumbnail, then crop.

• Double-click the Background layer in the Layers palette and name it "original".

• Duplicate the "original" layer, and name it "rollover". Choose Image>Adjustments>Hue/
Saturation. Lighten and desaturate the "over" layer.

• Hide the "rollover" layer. For the "original" layer, choose File>Save for Web. In the 4up tab, 
experiment with different optimization settings, jpg or gif. Save to your site images folder as 
rasterorig.

• Hide the "original" layer, and for the "rollover" state do a Save for Web. Save to your site 
images folder as rasterroll.

• In Dreamweaver, click the cell in which to add each rollover. Choose Insert>Image 
Objects>Rollover Image. In the dialog box, browse to your original file and then to your rollover 
file.



7. Preview your page in a browser

In this step you will:
• View a more accurate rendering of your page in progress using a Web browser.

Background Info: Dreamweaver does not provide the most accurate preview of your page. You 
must view your page in a browser, or several different browsers for comparison.

Do this: Choose File>Preview in Browser, and select either Safari or Firefox. Your page will 
open in that browser.

Note: If no browser choices are present, you will need to choose File>Preview in Browser>Edit 
Browser List... to tell Dreamweaver the location of the browsers installed on your hard disk. Click 
the + button and navigate up to the Desktop, then down through Macintosh HD/Applications to 
Firefox or Safari.

8. Duplicate your index page to create other pages for your site

In this step you will:
• Use the Duplicate command to make copies of index.html

Background Info: The design already laid out on your home page will become the foundation for 
the other pages in your site.

Do this: Save and Close "index.html". In your Site window, control-click on index.html and 
choose Duplicate. rename the resulting copy "about.html".

• Change the headline text at the top of the page to "About". Delete the thumbnails, bio text and 
their respective cells from the layout.

In the example, a cell height of 455 pixels was used for the image. Widths can be adjusted once the 
image is in place. The cell height for the text can be expanded as necessary.

• Save and Close then duplicate it again, renaming the copy "contact.html".

• Fill in these pages with applicable content.



9. Create links as shown in the sample site

In this step you will:
• Use the Point to File feature to link to a file in your site (relative link).
• Use the Property Inspector to link to a file or some other site (absolute link).

Background Info: You can create a hyperlink from text or from a graphic. Highlight the text or 
select a graphic. A Link field will appear in the Properties panel. Either use the Point to File cross 
hairs button to link to a file in your site (relative link,) or type the URL into the field to link to a 
page in another site (absolute link.)

Do this: Open index.html. Arrange the document window so that you can see some portion of the 
Site window behind it. Highlight the word "Home" in the links cell at the bottom of the page. Drag 
the Point to File button next to the Link field in the Properties panel to the index.html file listed in 
the Site window — just drag the pointer to any part of the Site window to bring it forward, then 
navigate to the proper file in the list.

• Select the thumbnail rollover graphics and link them to their appropriate pages.

• Select the Email text. In the Link field type "mailto:" immediately in front of an email address 
(such as mailto:blclark2@buffalo.edu. Use no spaces between the prefix and the address.

• Create the links on the other pages in your site. (In this example, you can copy the link text from 
index.html and paste it into the other pages, replacing the non-linked text.)

11. Test your site

Test your site locally: Test your site thoroughly, in as many different browsers and on different 
computer platforms, if available. When you are confident that there are no broken links and that all 
pages display as you like, proceed to upload your site to the Web server.

Do this: Choose Site>Check Links Sitewide. Repair any broken links that show up in the list.

12. Save a copy of your Local site folder to removable disk.

Archive your Web Portfolio folder, which includes your local site folder, to removable disk. You 
can edit the local site from any computer as long as you do not move the individual files within the 
site folder relative to each other.


